Шифратор 1С

В результате текст программы приводится к нечитаемому виду.

Пример:

Перем z09A1D100696E,zA8E5D31AC263,z1224287F391A,zC541400AFF53,
z331134D925E9,z25B73D1A480B,z3E6356D56060
,zE39F3BBF6FB4,zCBF7EA4D1967,z19D8B58AE181,zE037D3BAB8FC,
z71D6E52B999C,z9576A8A97B05,z3ECB216F3213,zA28A3D229584
,z778EF620D17B,zFA03BB1BA5BF,z0BCEBEEE2A8B,zB1C2A7D5D7B6,
z1EDE4E350EFA,z177DB322B571,z9FAB701699A1,z630773255216
,zF928132CEF9C,z5368A0886B17,zB7191DF2608A,z04F586C097C3,
zC3FA71AD0358,zBB2BFF927B7E,z25FD6954AE4F;Перем
zD31D2EF22ABF;Перем zA2ADB6112B5D;Перем zDD05AFE2A3B4;Перем
z46427946389A;Перем ТекстУсловия;Функция z5A0323B4A718
(z04AC2A7AA61F)Перем z98C6BEB1E3DF,z04FA687F1274,zF35868B0A6F3,
z5C8DC43CDB79;z98C6BEB1E3DF=Строка(ПолучитьПустоеЗначение
());z04FA687F1274=СтрДлина(z04AC2A7AA61F)/3;Для zF35868B0A6F3=1 по
z04FA687F1274 Цикл z5C8DC43CDB79=Строка
(999-Число(Сред(z04AC2A7AA61F,(zF35868B0A6F3-1)*3+1,3)));
z5C8DC43CDB79=Прав(Строка(0)+Строка(0)+z5C8DC43CDB79
,3);z5C8DC43CDB79=Прав(z5C8DC43CDB79,2)+Лев(z5C8DC43CDB79,1);
z98C6BEB1E3DF=z98C6BEB1E3DF+Симв(z5C8DC43CDB79
);КонецЦикла;Возврат z98C6BEB1E3DF;КонецФункции Процедура
ИзмТекстУсловия()Если УслИскл=0 Тогда ТекстУсловия
=z09A1D100696E;Иначе ТекстУсловия=zA8E5D31AC263;КонецЕсли;
КонецПроцедуры

В приведенной демонстрационной версии не производится анализ использования вызовов функций и переменных из печатных форм. Как следствие нельзя зашифровать отчеты, и прочие вещи, формирующие вывод печатных форм. Так же отсутствует шифрование текстовых констант (сообщений).

В КАТАЛОГ »