Проверка даты выхода на пенсию по новой пенсионной реформе

         После усиленного обсуждения пенсионной реформы и практически уже её принятия

Нашими законодателями я вспомнил что в начале двухтысячных годов пришлось определять 181 день после отгрузки товара со ставкой НДС 0% за того чтобы оформить зачет НДС. Бухгалтера считали дни вручную, по календарю и я смастерил простенькую обработку (181.ert) для определения даты зачета НДС.

Ну а потом пришлось уже разработать более продвинутую обработку. Она уже проверяла базу в пределах интервала в 5 дней до текущей даты и 5 дней после на предмет наличия отгрузок со ставкой НДС 0% и формировала счета-фактуры и записи в книгу продаж. То есть формировался полный комплект документов для зачета НДС.

Тут как – то не заметно пришло время готовиться к оформлению пенсии.

Ну я и решил по прикалываться над бухгалтерией и состряпал обработку (0Pens.ert), напоминающую работникам бухгалтерии сколько дней мне, осталось до пенсии, и чтобы они не забыли меня поздравить!

На скрине минусовое кол-во дней поскольку с 13.04.2009 года пошел обратный отсчет.

Чтобы это было не так надоедливо я включил вызов обработки в конфигурацию.

Вот этот фрагмент :

////*************************************

//                          // Проверка Victor pens
       Час = 0;            
      Сек = 0;            
                          ТекущееВремя(Час,Сек,);
           КаталогФорм = КаталогИБ()+"ExtForms\";
           Pens= КаталогФорм+"0Pens.ert";
                                         Если  Час < 10  Тогда//(ТекущееВремя(,,)>=) 10)
                                 
                                                      Если ФС.СуществуетФайл(Pens) = 1 Тогда
           ОткрытьФорму("Отчет.",,Pens);
                                                        КонецЕсли;
                                         ИначеЕсли  (Час = 10) И (Сек <= 30)Тогда//(ТекущееВремя(,,)>=) 10)
                                                        Если ФС.СуществуетФайл(Pens) = 1 Тогда
           ОткрытьФорму("Отчет.",,Pens);
                                                        КонецЕсли;
                                         КонецЕсли;
//           // Проверка Victor pens

////******************************************

Его я потом за коментил, но бухгалтерия была в восторге и старалась входить в базу после десяти, поскольку у женщин нашей фирмы с 9-00 до 10-00 чаепитие и обмен новостями.

 

Так что преамбула ясна.

С 2009 года прошло уже 9 лет фирма уже работает на Бухгалтерии 2.0 платформа 8.3 я уже давно практически не пишу обработки и доработки к конфигурациям, просто тупо обновляюсь и создаю резервные копии.

И вот решил проверить как посчитать нашим будущим пенсионерам сколько им еще ждать до пенсии по новым правилам и сварганил обработку под платформу 7.7 (02Pens.ert). Файл регистрации делать не стал.

Сделал обработку (Pens.epf) и для платформы 8.3 для конфигураций Бухгалтерия2.0 и Зарплата 2.5 на обычных формах, так что в Бухгалтерия3.0 и Зарплата 3.0 и 3.1 она работать не будет.

Сходу сделать обработку на УФ не получилось. Надо разбираться, а метод математического тыка, как правило быстрый результат не дает.

Выставляю для обозрения выше указанные обработки может кто-то ещё работает на 77 и 8.2.

В архиве обработка 02Pens.ert и для ознакомления 181. .ert и 0Pens.ert. для платформы 7.7

Для платформы 8.2 Pens.epf

 

 

В КАТАЛОГ »