Отказ от модальности. Баг в типовых конфигурациях

Предположим, что во внешней обработке на форме в событии “ПриОткрытии” использовалась комбинация “Ответ = Вопрос(…)”, которую в результате рефакторинга заменили на “ПоказатьВопрос(Новый ОписаниеОповещения(…), …)”. Если эту обработку открыть через “Файл -> Открыть…”, то код нормально отрабатывает, вопрос задается и ответ на вопрос обрабатывается. Если же эту обработку поместить в “Дополнительные отчеты и обработки”, то в этом случае при открытии обработки вопрос “моргает” (появляется и тут же исчезает). Я не случайно выделил в тексте название события, так как если использовать “ПоказатьВопрос” уже в открытой форме обработки (например, по кнопке), то он работает нормально.

Решил проблему следующим образом:

&НаКлиенте
Процедура ПриОткрытии(Отказ)

    ПодключитьОбработчикОжидания("ПроцедураОбработчикаОжидания", 1, Истина);

КонецПроцедуры

&НаКлиенте
Процедура ПроцедураОбработчикаОжидания()

    ОписаниеОповещения = Новый ОписаниеОповещения("ВопросПриОткрытии", ЭтотОбъект);
    ПоказатьВопрос(ОписаниеОповещения, "Текст вопроса", РежимДиалогаВопрос.ДаНет);

КонецПроцедуры

&НаКлиенте
Процедура ВопросПриОткрытии(РезультатВопроса, ДополнительныеПараметры) Экспорт

    // Текст процедуры

КонецПроцедуры

В КАТАЛОГ »