[ОБУЧАЛОВКА] ТиС: проблемы с позиционированием строки в ТЧ документа после закрытия подбора

В ТиС’е наблюдается такая проблема: в ряде случаев при завершении подбора в табл.часть документа курсор позиционируется черти знает куда и теряется последняя подобранная строка… О причине проблемы распространятся не буду (некорректная работа с переданным контекстом), будем лечить…
В глобальном модуле ищем процедуру глОбработкаПодбора(…) идем в конец процедуры, видим там типа

    ...
    КонецЕсли;
	
    Конт.АктивизироватьСтроку(Конт.КоличествоСтрок());
    Конт.Активизировать("Количество");
    Конт.Форма.Обновить(0);
КонецПроцедуры // глОбработкаПодбора()

превращаем данный код в “правильный”:

    ...
    КонецЕсли;

    Конт.Форма.Обновить(0);
    Конт.АктивизироватьСтроку(Конт.КоличествоСтрок());
КонецПроцедуры // глОбработкаПодбора()

Все. Пользуемся.
Кому пригодилось – не забываем плюсовать рейтинг!

В КАТАЛОГ »